Debian

From dankwiki
Would you like some fries with that elitism?

It's the bees' knees. It's the wasps' nipples (though as of 2019, I have actually started using Arch).

  • Things I do to a new Unstable (sid) box
  • Packages by Purpose
  • My resolution this year is to file bugs in the DBTS more quickly and more often. Well, it isn't really, but I ought do so. Bugs filed thus far, and their resolutions:
    • #926743, fetchmail can't find invoke-rc.d (provided patch)
    • #925443, dovecot-core refers to deprecated /var/run (provided patch)
    • #924585, memcached refers to deprecated /var/run (provided patch)
    • #924584, memcached new version 1.5.12 available
    • #920308, compiz-core test is inverted in compiz-decorator (provided patch, resolved)
    • #917581, nlohmann-json3 new version 3.4.0 available (resolved)
    • #904587, libconfig-dev missing CMake support
    • #845066, libmsgpack-dev new 2.0.0 available (resolved)
    • #839767, ncmpcpp needs rebuild against new libtag (resolved)
    • #801657, libdevmapper-dev don't exp%drotsInPydd1ose librt dep (resolved)
    • #801430, aptitude segfault on dependency loop (resolved)
    • #469601, nut-hal-drivers locks up on post-install
    • #469937, statsvn has problems with filenames containing spaces (fixed upstream, resolved)
    • #471111, mpd isn't shut down properly
    • #509499, strace doesn't match sendfile(2) properly (provided patch, resolved)
    • #530154, bugz doesn't provide a man page
    • #533360, libc6 2.9-15 broke signalfd creation with SFD_* flags (resolved)
    • #533362, ia32-libs uninstallable against libc6 2.9-15 (resolved)
    • #552260, kernel-package with install_vmlinux set + grub2 == unbootable entries
    • #553298, libcpuset drops core if an empty cgroup/cpuset fs is mounted
    • #554901, eglibc is missing const casts in CPU_ISSET() (provided patch, resolved)
  • I'd also like to become a Debian Developer. ITP ideas:

Building kernels

Up until the addition of a deb-pkg (and bindeb-pkg) target to the kernel Makefile in 2004, the make-kpkg tool from kernel-package was the recommended way to build a Debian kernel package. This is now deprecated, and deb-pkg ought be used going forward.

To specify the package version on the command line, use e.g. KDEB_PKGVERSION=$(make kernelversion)-2.